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1.  Preface 

The eTurboTouch touch panel is the most intuitive pointing device available for 
the PC series of computers and monitors. Touch panels make using computers as 
simple as touching the screen. It is ideal for a variety of applications, including 
entertainment, training systems, information, point-of-sale, factory automation, 
laboratory and medical instrumentation, interactive selling demonstrations, 
educational programs and so on. 

To use the Touch panel with your host computer or device, you have to install 
controller, the touch panel and the corresponding software. For the instruction of 
installing touch panel, refer to Sensor Kit Installation Guide. For the hardware 
connections for your controller, please refer to the Controller reference guide. 

Introduction 

eTurboWare converts the data from the touch panel to emulate input from a 
mouse device. eTurboWare for DOS is the software for the eTurboTouch touch 
panel. It provides full touch panel functionality for all applications running under 
DOS environment. 

After you finished installing eTurboWare, you can select and drag objects using 
the touch panel. To make a selection, simply touch the screen slightly. 

This manual provides the following information and will be described later by 
chapters. 

n Install this software 

n Use the touch panel (control panel) to customize your work environment 

n Troubleshooting  

♦ Important: Before installing software, you must complete the appropriate 
hardware connections for your controller and touch panel. 
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Installation 

To install the eTurboWare for DOS, please follow the steps below: 

1. Insert the eTurboWare CD into your CD-ROM drive. 

2. Change from C drive onto the drive of your CD-ROM. 

3. Type in “Install”. The installation procedure starts. Please wait for a moment 
for installing the appropriate files from the CD to your hard disk. 

When you installed a brand-new controller, you have to do 2-point calibration 
first before using. Please use mouse or keyboard to finish the work.  

Support Services 

eTurboTouch provides technical support to help you solving the problem that 
you might encounter. Before you contact to our service center, please write 
down, 

n The type of the sensor that you have 

n The version of the driver 

n The firmware version for the controller 

n Description of the problem briefly 

Preparing the above information can save the time to help you solving the 
problem. You can contact to us by giving a phone call, sending a fax, or 
electronic mail. 

Tel: 886-3-4547599 
Fax: 886-3-4547555 
Website: www.eturbotouch.com 
E-mail Address: service@eturbotouch.com 
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2.  Using eTurboWare 

You can change the software settings for your system, such as changing the 
calibration methods, touch modes, cursor options, hardware, and diagnostic tools 
to suit your preferences. 

To make sure you can invoke command with a touch, two steps listed below 
should be done.  

n Calibrating your screen, refer to page 9 

n Configuring the mouse mode, refer to page 14 – Touch Setting  

Using eTurboWare 

To open eTurboWare, please do the following: 

1. Change onto the directory where eTurboWare application software located. 
2. Type “tpdiag.exe” and press Enter. 

The Diagnostics Utility screen will be shown as the following. There are four 
main items that you have to pay attention – File, Option, Tools and Help. 
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File Menu 

After you open the eTurboWare, the first thing that you have to do is to select the 
correct communication port for your touch panel. That is, to find the interface for 
communication such as COM Port, PS/2 port setting for your sensor.  

        
Move the mouse cursor onto the File menu. There are two menu items that you 
can find, Open and Exit. For choosing the communication port, please select 
Open menu item. Three options of communication ports provided here for your 
selection. 
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Choose the one that connected to the touch panel. The one that you select will be 
marked with a star sign. 

Calibrating Your Screen 

To make the touch panel to locate the correct position for each touch, you have to 
do calibration after the hardware and software installation are finished.  

When should you calibrate the screen: 

l The first time you run eTurboWare, you have to do 2 points calibration first. 

l Each time you change the video resolution (for example 640x480 or 
800x600) or video mode of your monitor.  

l Any time you change the size of the video image by adjusting the horizontal 
and vertical controls on your monitor.  

l If the cursor does not follow the movement of your finger (pointing device), 
or cannot reach the edges of the screen. 

2-Point Calibration 
To have a 2-point calibration, please 

1. Select Panel Mapping menu item from the Option menu.  

 

2. A screen with two calibration points appears. 
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3. Touch on the blinking one with your finger or pointing device for a while. If 
it is OK, the point will change into a yellow cross and keep steadily. 

♦ Note: The calibration screen will exit automatically if you do not 
touch on the blinking point for calibration after a short time.  

4. Now, finish the second point calibration. 

5. You have done the panel mapping.  

5-Point Calibration 
To have a simple mapping with linearization compensation, execute 5-point 
calibration to get the result. When you select this function, 5 points display on 
your screen. Please touch on it in a while until it changed color into green (means 
calibration of that point is OK) and then release your finger or pointing device.  

To have a 5-point calibration, please 

1. Select 5pt Calibration menu item from the Tools menu.   
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2. The screen with 5 points for your calibration appears. The top-left point 
blinks to push you to do the calibration. 

 

3. Touch on the blinking one with your finger or pointing device for a while. 
If it is OK, the point will change into a yellow cross and keep steadily. 

♦ Note: The calibration screen will exit automatically if you do not 
touch on the blinking point for calibration after a short time.  

4. Follow the instruction on the screen to touch every point.. 

5. When you finish these steps, you have done the panel mapping. 

25-Point Calibration 
This command defines the X and Y axis position for a touch. When you select 
this command, 25 points with black background will display on your system 
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screen. The point to the left-top side will blink to ask you to do the calibration. 
Please touch on it by your finger or any point device in a while until it changed 
from blinking into steady cross.  For calibration, you have to touch 25 points 
one by one. 

♦ Note: As this command is used for compensation if the touch panel got 
some problem of bad linear, it is not recommended to invoke it.  

For 25-point calibration was done by factory as a default setting, in general, you 
do not need to execute this action again. Yet, if you really want to do, please 
follow the steps below: 

1. Select 25pt Linearization menu item from the Tools menu.  

 

2. The screen with 25 points for your calibration appears.  
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3. Touch on the blinking one with your finger or pointing device for a while. 
If it is OK, the point will change into a yellow cross and keep steadily. 

♦ Note: The calibration screen will exit automatically if you do not 
touch on the blinking point for calibration after a short time.  

4. Follow the instruction on the screen to touch every point. 

5. When you finish these steps, you have done the panel mapping.  

Draw Test Window 
The Draw Test Window is provided for you to do simple test of finger touch. 
You can draw lines with your finger or any pointing device.  

To clear the trail of your drawing test, click Clear  to clean it. To exit this 
window, please press Exit button on the screen. 

 

Terminal Window 
This tool allows you to type firmware command on the command line. The result 
will be shown on the below terminal message window. 
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Touch Setting 

You might want to configure some settings after installing eTurboWare. Use the 
Option menu to set touch setting whenever you want. 

Mouse Mode 
You can choose a touch mode for your necessity. For choose the proper touch 
mode, please open the Option menu, and you will find three selections are 
provided here. 

 

Button Mode 
In Button mode, touching the screen is equal to pressing and/or releasing the 
mouse button. 
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Drawing Mode  
Drawing mode is useful for draw and graphics applications. In Drawing mode, a 
touch is equal to pressing and holding down the mouse button. Lifting off your 
touch is the same as releasing the mouse button.  

Click Mode 
It is useful for general-purpose desktop applications. In this mode, a touch 
positions the cursor much like a mouse. Holding the touch is equal to pressing 
and holding the mouse button. Lifting the touch off is equal to releasing the 
mouse button. 
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Mouse Mode Parameter 

 

Drawing Delay -  Defines the time that you must touch the screen for your 
system to interpret your actions as a click. Adjust it to the 
right to set the range for each touch be larger; adjust it to the 
left to set the range for each touch be smaller.  

Click Delay-  Defines how quickly you must touch the screen for your 
system to interpret your actions as a click. Adjust it to the 
right to set the speed for each touch be slower; adjust it to 
the left to set the speed for each touch be faster. 

InPlace -  The Inplace defines the area (range) in which you must 
touch the screen for your system to interpret your actions as 
a click. 

eTurboWare Mouse Icon 

A button to the right-bottom of the mainscreen is used to switch between left and 
right button function for a touch. 

 

This button can apply the right mouse button function for a touch. The limitation 
is that it can be used just once. If you want to apply the function for next use, you 
must press this button again. 

On-Line Help 

eTurboWare will offer an on-line help for your reference whenever you want to 
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know the detailed information about each commands in the future. Now current 
version information for eTurboWare will be shown when you choose About 
menu item from Help menu 

. 

Exiting the eTurboWare 

When you finish all the setting adjustments, you can exit the main screen of 
eTurboWare. Choose Exit from the File menu to make all the settings take effect.  
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3.  Troubleshooting 

This  chapter will provide you some notice and specific information for your 
reference. 

Important Notice 

n If you have to do a 25-point calibration, please do the 5-point calibration 
first and clear the hardware information recorded in the controller. To do this, 
click the 25Parameter tag – choose “Clean” – click “Download” and quit. 

n If you have rotated the sensor for some reason, before using it, please 
execute 2-point calibration. The 2-point calibration will not affect 5-point 
and 25-point calibration unless re-calibrated. 

n For LCD video rotation, it is not necessary to do re-calibrate with 2-point. 
The LCD video coordinate is separate from touch coordinate. 

n The driver/utility v1.05 is compatible with firmware 1.00 and later. Before 
you install a new driver /utility to your system, please check the controller 
firmware’s version. Choose About Touch button from the Controller List 
dialog box to get the firmware and driver version information. 

n The touch panel provides less 1.5 accuracy fail message. The 1.5% length of 
sensor active area and 1.5% wide of sensor active area offset is acceptable. 
However, the calibration accuracy will affect this result and sensor size. 
Besides, the larger offset distance will appear. 
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